Subscribe
  1. Boba Swede's Avatar
    Member Since
    May 2004
    Posts
    938
    May 3, 2008, 4:43 AM - HELP! Paintbrush trouble! #1

    As the title says.. I'm having major trouble with my paintbrush..

    at first it worked fine but then it started to blow air into the paintcontainer!! So no paint was coming out.. only air.

    So i switched to pure water and just sprayed hoping that if there was a clog then this would clear it out.. but it didn't help.

    So.. anyguess to what the problem could be and how do i prevent it from happening again?!
  2. DeadasaJodo's Avatar
    Member Since
    May 2008
    Posts
    185
    May 3, 2008, 11:05 PM - Re: HELP! Paintbrush trouble! #2

    I wish I could help but air brushes counfound me. I bought one about 10 years ago and have never had the nerve to take it out of its packageing. Personally I always use rattle/spray cans and for the most part they work just fine.
  3. erock8100's Avatar
    Member Since
    Feb 2008
    Posts
    53
    May 3, 2008, 11:11 PM - Re: HELP! Paintbrush trouble! #3

    I had the same problem awhile back when i got my first air brush. So, I went to PEARL paint, and picked up something called "auto-air colors" Its like a airbrush restorer. I let it sit in a jar for about 12 hrs and the next it worked fine..Hope this helps...
  4. Jluck's Avatar
    Member Since
    Mar 2007
    Posts
    441
    May 4, 2008, 11:54 AM - Re: HELP! Paintbrush trouble! #4

    airbubbles in the color cup usually means you have a clog or debree built up on the needle. or it can mean the aircap etc need to be tightened. first tighten the aircap, see if that helps. if not disassemble the front end ( aircap, tip etc.) and remove the needle. let those parts soak for a couple few hrs in parts cleaner or window cleaner w/ amonia. inspect the barrel and make sure theres no build-up in there either and use pipe cleaners (soft) to clean the barrel. once you cleaned all that stuff re-assemble and run some window cleaner or water through it to test it out. this should solve the problem.

    do not soak the entire airbrush. you have gaskets in the airvalve assembly that cannot get wet and can damage if you do.

    hope this works for ya
  5. Boba Swede's Avatar
    Member Since
    May 2004
    Posts
    938
    May 4, 2008, 3:55 PM - Re: HELP! Paintbrush trouble! #5

    thanks alot for the help Jluck. i'll take your advice and see what happens..

Similar Threads

  1. trouble with PMs anyone?
    By daric larone in forum Site Support & News
    Replies: 3
    Last Post: Apr 15, 2010, 9:03 PM
  2. I got in trouble for laughing at this..
    By Dark Jedi in forum The Sarlacc Pit
    Replies: 21
    Last Post: Dec 20, 2008, 9:23 AM
  3. fiberglass trouble...
    By swspiffy in forum Boba Fett Helmet
    Replies: 37
    Last Post: Nov 22, 2008, 2:28 AM
  4. LED Trouble!! Help me please!
    By tk9950 in forum Boba Fett Costume
    Replies: 16
    Last Post: Sep 13, 2008, 1:57 AM
  5. trouble with my sig pic...
    By Zurath Kodul in forum Site Support & News
    Replies: 6
    Last Post: Aug 28, 2008, 3:44 PM