Airbrush problem...help please

  1. #1
    Wildabeast's Avatar
    Member Since
    Jan 2007
    From
    Alberta,Canada
    Posts
    547

    Airbrush problem...help please

    After a very long time I took out my Paasche double action airbrush to do some weathering and after the first 5 minutes the air started coming back into the paint cup causing the paint to bubbling out. I have since soaked and cleaned the airbrush, but still am having the same issues. Any suggestions??

    W

  2. #2
    Jluck's Avatar
    Member Since
    Mar 2007
    From
    michigan
    Posts
    441

    Re: Airbrush problem...help please

    ~first, how did u soak the brush?? did u emerse the whole air brush or dissasemble it? if u soaked the whole brush u can damage it causing the gasket in the air valve seat to absorb moisture which then casues air leaks... ~ second do u have a moisture trap on ur hose line? u may have debree in ur air vale seat as well.....also make sure ur the needle guide is tightened properly, and ur tip as well. also what psi are u running at?? for paint and med weight materials u should be between 15-35 psi ( 20-25 in most cases).........if all this fails, dissamble the entire brush, do not soak the rubber gaskets, but clean them w/ a q -tip soaked in airbrush cleaner, then soak all ur metal parts in clenaer over nite if u need to. it usually a old paint clog or a air leak that casues ur problem... ne questions feel free to pm me

  3. #3
    eighteendelta's Avatar
    Member Since
    Apr 2007
    From
    Pottsville PA
    Posts
    255

    Re: Airbrush problem...help please

    Are you using canned air or a compressor? If canned air, you may be getting freeze issues. If it takes some time and doesn't happen from the outset then that would be my first guess.

    -x

  4. #4
    CGClone's Avatar
    Member Since
    Feb 2005
    From
    Cordova, TN
    Posts
    556

    Re: Airbrush problem...help please

    Sounds like a good 'ol paint clog. Jluck nailed your cleaning treatment on the head.

    Try spraying a test run without the tip and run down his cleaning steps from there.

  5. #5
    Wildabeast's Avatar
    Member Since
    Jan 2007
    From
    Alberta,Canada
    Posts
    547

    Re: Airbrush problem...help please

    Thanks for all the help guys. Like I said I hadn't taken the brush out in years. I did soak the metal pieces over night. I am starting to think that the gaskets may be no good. Any ideas were to find new ones??

  6. #6
    Jluck's Avatar
    Member Since
    Mar 2007
    From
    michigan
    Posts
    441

    Re: Airbrush problem...help please

    first, look at the gaskets. are they "smushed" looking or dry rotted? and also the smallest particle of paint, and i mean small can casue issues. in most cases so small u cant really see it. take a pipe cleaner with " fine" bristles, soak it w/ cleaner then run it through the barrell of ur brush severla times. then inspect it for any discoloration. if u see some spots still use a dental pick or a sewing needle and VERY gently scrape it away. do this w/ all parts metal " needle, barrell, tips, needle guide tip etc" does ur needle feel " hard" to push through the brush?? if so t hat can tell u that u still have a clog or possibly even a bent needle tip, so inspect ur needle as well.... and if u have a local hobby shop that sells pacche they should stock ur replacement parts. if not u can go to there website and get some things there....let me no if u need more assitance. ill be glad to help

  7. #7
    SaxeCoburg's Avatar
    Member Since
    Oct 2004
    From
    Knoxville Tenn.
    Posts
    863

    Re: Airbrush problem...help please

    Also I use a "sonic cleaner" (for jewellery, $25 at walmart) that I put my airbrush parts in. As mentioned above, do NOT soak any parts that have the rubber/plastic gaskets.

Similar Threads

  1. Question: sizing problem...
    By ARC3582 in forum Boba Fett Helmet
    Replies: 3
    Last Post: Sep 21, 2008, 3:47 AM
  2. Problem
    By Boba Luke in forum Boba Fett Helmet
    Replies: 12
    Last Post: Apr 20, 2008, 5:37 AM
  3. Houston we have a problem...
    By Puck in forum Boba Fett Costume
    Replies: 3
    Last Post: Apr 17, 2005, 8:13 PM
  4. Right Ear problem
    By Fett4u in forum Boba Fett Helmet
    Replies: 1
    Last Post: Jun 8, 2003, 12:55 PM
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •