Problem with my first helmet

  1. #1

    Problem with my first helmet

    Hey I'm new to the forum, and just started on my first helmet.
    I have ran into a big problem. I use an expoxy that dries great on the helmet, but leaves these huge uneven ridges and gaps. I spent hours trying to smooth it put but to no avail. I tried to sand it out but it is impossible to smooth out. Any suggestions? I was thinking a "rubber in a can" sort of thing.

  2. #2
    FettFanatic's Avatar
    Member Since
    Aug 2006
    From
    Oklahoma City
    Posts
    749

    Re: Problem with my first helmet

    If you post a pic it might make it easier to understand the problem and give suggestions on how to fix it.

  3. #3

    Member Since
    Feb 2013
    From
    California
    Posts
    31

    Re: Problem with my first helmet

    To really smooth it out, use bondo and progressively use finer sand paper. It'll fill in small divits and have a nice smooth foundation. The "rubber in a can" will be hard to smooth out nicely.

    I've yet to get to that point on my helmet, but this is just tips from doing body work and interior work on my car. But yes, I agree with FettFanatic, pictures would be good.

  4. #4

    Re: Problem with my first helmet

    fetthelm-jpg

    Hopefully this works..

  5. #5
    FettFanatic's Avatar
    Member Since
    Aug 2006
    From
    Oklahoma City
    Posts
    749

    Re: Problem with my first helmet

    You could use bondo over the epoxy. It is very easy to smooth and sand.

  6. #6

    Member Since
    Jan 2013
    From
    Sheffield uk
    Posts
    11

    Re: Problem with my first helmet

    Sorry I am new to this site and don't know how to use it rite yet I have a asi scope for sale and don't know how to put it on the site if any one could help thanks zuco

  7. #7

    Member Since
    Dec 2012
    From
    Kent , UK
    Posts
    273

    Re: Problem with my first helmet

    Hi as a new member you are restricted to certain areas , the cargo hold is one of them , you should get a coloured band at the top of the page with a heading new members or something like that , if you read that it will explain what and why the restrictions are there, I think you need to of made five posts and of been a member for a week before you can put items up for sale, hope this helps , edited my post as I thought you were the original starter of this thread , in future you might get a quicker response if you start your own thread , and not trample over someone else's
    Cliff
    Last edited by ICEmonkey; Feb 15, 2013 at 11:09 AM.

  8. #8

    Member Since
    Dec 2012
    From
    Kent , UK
    Posts
    273

    Re: Problem with my first helmet

    If it was mine I would hit the high areas with a flapper wheel in a demel, and as said fill in the dips with a easy sand filler

  9. #9

    Re: Problem with my first helmet

    Alright thanks for the advice but I just realized that I need to make the famous dent... Any suggestions?

  10. #10

    Member Since
    Dec 2012
    From
    Kent , UK
    Posts
    273

    Re: Problem with my first helmet

    My helmet was a jango lid so it had no dent , the previous owner made a small dent with a dremel ,but it wasn't screen accurate so I dremeled out the hole then got some epoxy putty and added to the inside ad sculpted a rough dent shape, when it was set I added the detail

  11. #11

    Member Since
    Jan 2013
    From
    Sheffield uk
    Posts
    11

    Re: Problem with my first helmet

    How do u start your own thread

  12. #12
    RafalFett's Avatar
    Member Since
    Oct 2010
    From
    Galati, Romania
    Posts
    2,634

    Re: Problem with my first helmet

    Zuco said: View Post
    How do u start your own thread
    Go to the section you want to start your thread (ex: Boba Fett Helmet), then when the page opens, in the upper left part you will find the '+ Post New Thread' button. Press it and you can add the title and content of your new thread.

Similar Threads

  1. New user here with a problem.
    By apex in forum Site Support & News
    Replies: 12
    Last Post: Nov 25, 2012, 1:28 PM
  2. Question: SUBMITTING AD PROBLEM
    By yodakiller1138 in forum Site Support & News
    Replies: 3
    Last Post: May 22, 2009, 3:22 PM
  3. Problem
    By Boba Luke in forum Boba Fett Helmet
    Replies: 12
    Last Post: Apr 20, 2008, 5:37 AM
  4. masking problem?
    By mattstrikesback in forum Boba Fett Helmet
    Replies: 7
    Last Post: Sep 26, 2004, 9:45 PM
  5. Helmet Problem HELP
    By Captain4434 in forum Boba Fett Helmet
    Replies: 5
    Last Post: Nov 8, 2003, 5:46 PM
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •