Subscribe
  1. Golgotha's Avatar
    Member Since
    Mar 2004
    Posts
    148
    Mar 16, 2004, 7:26 PM - LED's Installed! #1

    Just got done Installing some LED's in my bucket. These are alternating red and green LED's. The on/off switch is located inside the helmet and is powered by a 9 volt battery. Here are a few pics!











    Later,

    Bryan
  2. Admin Staff webchief's Avatar
    Member Since
    Mar 2002
    Posts
    4,704
    Mar 16, 2004, 7:31 PM - Re: LED's Installed! #2

    Cool!
  3. Member Since
    Aug 2003
    Posts
    218
    Mar 16, 2004, 9:04 PM - Re: LED's Installed! #3

    I like it!

    TK0907/Chris
  4. Admin Staff Star Wars Chick's Avatar
    Member Since
    Mar 2002
    Posts
    5,575
    Mar 16, 2004, 10:33 PM - Re: LED's Installed! #4

    That is very cool.
  5. Golgotha's Avatar
    Member Since
    Mar 2004
    Posts
    148
    Mar 16, 2004, 10:34 PM - Re: LED's Installed! #5

    Thanks everyone. I am pleased with the results!

    Bryan

Similar Threads

  1. who installed the Boba sound in his costume?
    By volkerc in forum Boba Fett Costume
    Replies: 76
    Last Post: 3 Weeks Ago, 1:23 AM
  2. Installed visor question
    By AncientFett in forum Boba Fett Helmet
    Replies: 4
    Last Post: Jun 30, 2008, 2:05 PM
  3. listening device installed
    By BH2372 in forum Boba Fett Helmet
    Replies: 9
    Last Post: Mar 5, 2006, 1:26 PM
  4. Post pics of your helmet with Borden connector installed!
    By Fetthunter in forum Boba Fett Helmet
    Replies: 14
    Last Post: Aug 3, 2005, 3:58 PM