Subscribe
  1. Member Since
    Feb 2007
    Posts
    21
    Apr 8, 2007, 2:42 PM - Painting went wrong? #1

    Okay i bought some fan made armour and set to work as my first attempt. Pictured is the paint job that it came in.
    I started painting it and started with the metal undercoat. That looked pretty good so obviously I moved on to the yellow. No problems either.
    Finally, the green. And not to put too fine a point on it, it looks like someone who can't paint very well has painted on a bad day. It doesn't look like armour at all.
    I'm gonna have to sand and start again.
    What am I not doing. I read about acrylic wash. What is that? and powder spraying black. What does that mean. Any tips gratefully received.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00474.jpg 
Views:	288 
Size:	59.8 KB 
ID:	16910   Click image for larger version. 

Name:	DSC00489.jpg 
Views:	281 
Size:	50.6 KB 
ID:	16911  
  2. Jluck's Avatar
    Member Since
    Mar 2007
    Posts
    441
    Apr 8, 2007, 3:30 PM - Re: Painting went wrong? #2

    hey man, first lemme ask u, did u primer over the old paint first or "paint" over the old paint?? pm me and ill help u out more
  3. bobamaker's Avatar
    Member Since
    Apr 2004
    Posts
    714
    Apr 8, 2007, 4:08 PM - Re: Painting went wrong? #3

    You won't have to sand the paint off, try using 'Acetone' (nail polish remover), this will dissolve the paint for you. It's a bit smelly, but will save you loads of time. Don't try this if the armour is made form plastic though

    DAZ
  4. Member Since
    Feb 2007
    Posts
    21
    Apr 9, 2007, 4:28 AM - Re: Painting went wrong? #4

    Quote bobamaker said: View Post
    You won't have to sand the paint off, try using 'Acetone' (nail polish remover), this will dissolve the paint for you. It's a bit smelly, but will save you loads of time. Don't try this if the armour is made form plastic though

    DAZ
    Thank you for that. Will do

Similar Threads

  1. What's wrong?
    By chibi fett in forum Prop Building Workshop
    Replies: 12
    Last Post: Nov 20, 2008, 1:23 AM
  2. Where did things go wrong?
    By Cruzer in forum The Sarlacc Pit
    Replies: 29
    Last Post: Oct 9, 2008, 10:08 PM
  3. What's wrong
    By Tener in forum Boba Fett Helmet
    Replies: 2
    Last Post: Jul 15, 2008, 9:01 PM
  4. What's wrong with this picture?
    By TD2253 in forum The Sarlacc Pit
    Replies: 19
    Last Post: Feb 17, 2008, 2:10 PM
  5. Did i do wrong?
    By mandalorian76 in forum Jango Fett Costume
    Replies: 29
    Last Post: Dec 18, 2007, 12:11 PM