is this normal

  1. #1
    dlzx9r's Avatar
    Member Since
    Nov 2009
    From
    madison,ms.
    Posts
    748

    is this normal

    the 9 volt batt. in my left gantlet gets hot . feels like it would burn my arm if i left it on long enuf . is that how it is or did i not do somrthing right ?
    this is my first fett ,and first costum .
    thanks guys


    even off its getting hotter and hotter
    Last edited by dlzx9r; Oct 13, 2010 at 3:11 PM.

  2. #2

    Member Since
    May 2010
    From
    Novi Sad,Serbia
    Posts
    168

    Re: is this normal

    could be a normal thing,could be a short could be lots of things...thats more of a question for an electronics expert then costumers mate

  3. #3
    dlzx9r's Avatar
    Member Since
    Nov 2009
    From
    madison,ms.
    Posts
    748

    Re: is this normal

    i'm not an expert on either one lol . figured somone here was both .
    thanks anyway brother

  4. #4
    cjack350's Avatar
    Member Since
    Jul 2010
    From
    Home Sweet Home, NJ
    Posts
    118

    Re: is this normal

    That doesn't sound normal at all...

  5. #5
    dlzx9r's Avatar
    Member Since
    Nov 2009
    From
    madison,ms.
    Posts
    748

    Re: is this normal

    thanks again cjack . probley in my wiring . don't see how i could have messed it up thought.

  6. #6
    cjack350's Avatar
    Member Since
    Jul 2010
    From
    Home Sweet Home, NJ
    Posts
    118

    Re: is this normal

    Sorry I couldn't be more helpful, I'm far from an electronics expert. I just know that if a battery is getting hot enough to burn you then something isn't right.

  7. #7

    Member Since
    May 2010
    From
    Novi Sad,Serbia
    Posts
    168

    Re: is this normal

    did you check if the battery is leaking,usually the cause for battery heat up is either a short somewhere in the wiring or leakage of battery fluid

  8. #8

    Re: is this normal

    I had the same problem with my jetpack becon... the battery pack got so hot that I send it back to bobby fett uk.. Rob fixed it and I got a new batterypack just some days later, and it works fine now.. I would ask Rob sure he can help you ;D

  9. #9
    Lucksy31's Avatar
    Member Since
    Apr 2007
    From
    Plymouth Meeting, PA, 19462
    Posts
    2,220

    Re: is this normal

    What is your battery hooked to? Fans, LED's, etc...?

    Sounds like you have the (+) and (-) voltage reversed or the incorrect voltage applied to the source(ie: 9v battery to a 3v LED).

  10. #10
    dlzx9r's Avatar
    Member Since
    Nov 2009
    From
    madison,ms.
    Posts
    748

    Re: is this normal

    it's a 12 volt led light . radio shack ppl said it would work . just would be a little dimmer . i changed the batt. and that one gets hot too. would the magnets on my gantlet efect it ?? i checked my soilder to be sure it was not touching looks good . the wires are colored so they are not crossed . thinking the batt. plug might be bad . ??

  11. #11

    Member Since
    Jul 2010
    From
    Texas
    Posts
    94
    Do you have a switch on it? What kind?

  12. #12
    dlzx9r's Avatar
    Member Since
    Nov 2009
    From
    madison,ms.
    Posts
    748

    Re: is this normal

    toggle switch 3a at 125vac / 1a at 250vac

  13. #13
    Lucksy31's Avatar
    Member Since
    Apr 2007
    From
    Plymouth Meeting, PA, 19462
    Posts
    2,220

    Re: is this normal

    dlzx9r said: View Post
    it's a 12 volt led light . radio shack ppl said it would work . just would be a little dimmer . i changed the batt. and that one gets hot too. would the magnets on my gantlet efect it ?? i checked my soilder to be sure it was not touching looks good . the wires are colored so they are not crossed . thinking the batt. plug might be bad . ??
    You need to swap out that LED for a 9V version. It's drawing more current that it's rated for. Sure it will work, but it's not really designed for it. Just becuase it "will" work doesn't mean it's a good idea. I can drive my car with my feet, but I dont!!!

    The magnet would have NO effect. Hope that helps bro!

  14. #14
    dlzx9r's Avatar
    Member Since
    Nov 2009
    From
    madison,ms.
    Posts
    748

    Re: is this normal

    thanks scott. i'll do that . should have known but could not find one there.


  15. #15

    Member Since
    Jul 2010
    From
    Texas
    Posts
    94
    Lucksy31 said:

    You need to swap out that LED for a 9V version. It's drawing more current that it's rated for. Sure it will work, but it's not really designed for it. Just becuase it "will" work doesn't mean it's a good idea. I can drive my car with my feet, but I dont!!!

    The magnet would have NO effect. Hope that helps bro!
    Yes.
    If you did what I did you have an LED with a resistor built in. I'm not sure Radio Shack (where I got mine) has a 9v LED, and a red with no resistor is 2v so you'll have to add your own. Or use AA like I did. It takes a lot of room in the gauntlet but it feels a lot more snug on my arm.

  16. #16
    dlzx9r's Avatar
    Member Since
    Nov 2009
    From
    madison,ms.
    Posts
    748

    Re: is this normal

    thx kthur . it does have a resistor . i could not find a 9 volt light . think i'm going to start over and go to another radio shack .
    thanks for the info guys .

  17. #17
    dlzx9r's Avatar
    Member Since
    Nov 2009
    From
    madison,ms.
    Posts
    748

    Re: is this normal

    got all new stuff and re-did . works great now .
    thanks guys

Similar Threads

  1. Is this normal?
    By Madrid Boba in forum The Sarlacc Pit
    Replies: 4
    Last Post: Sep 10, 2008, 7:11 PM
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •