Subscribe
  1. Member Since
    Nov 2003
    Posts
    458
    Mar 5, 2004, 11:21 AM - Anyone had Problems Using Reefer Yellow on Armor #1

    Hello all,

    Just a quick question if anyone has had experience using Reefer Yellow as per the RS colour list in the helmet thread? I was trying to paint my shoulder bells last night and noticed that the paint (at least my bottle) was very thin.

    I used up 1/4 ounce (plus thinner) painting one bell and you can still see the chrome underneath. I was spraying it on evenly and light to prevent runs. It looks like it will take at least another 1/4 ounce + thinner.

    This seems like a lot to me. Especially since the US Med Green went on a lot nicer. I mean I painted everything but my backplate with 3/4 ounce + distilled water.

    I was wondering if this colour is just that thin and it will take that much paint or maybe I got a bad patch. I was thinking of not even thinning the paint for the second coat but I am not even sure that will help out much.

    Any ideas?

    Thanks in advance!

    Loranar
  2. Member Since
    Jan 2003
    Posts
    105
    Mar 5, 2004, 1:11 PM - Re: Anyone had Problems Using Reefer Yellow on Armor #2

    I went through the same thing. I think it's just a property of that particular paint. I layed mine on pretty thick over a time and it came out looking good. You won't really notice how thick it is once you get a flat coat on top of it.

    Hope that makes you feel better!

    Geoff
  3. Member Since
    Nov 2003
    Posts
    458
    Mar 5, 2004, 2:19 PM - Re: Anyone had Problems Using Reefer Yellow on Armor #3

    Thanks Geoff!

    I figured as much and I still think the colour will be spot on. Glad to hear it turned out for you.

    Loranar
  4. Lynn TXP 0369's Avatar
    Member Since
    Mar 2002
    Posts
    1,785
    Mar 5, 2004, 8:23 PM - Re: Anyone had Problems Using Reefer Yellow on Armor #4

    I used almost a 1 full oz. of the reefer Yellow on my bells + the thinner. Remember you'll also be hitting them with the UP armor yellow also a little as well.

    FYI..... Plan on at least a full 1oz. on the knees as well...

    Lynn

  5. Member Since
    Nov 2003
    Posts
    458
    Mar 24, 2004, 11:29 AM - Re: Anyone had Problems Using Reefer Yellow on Armor #5

    Thanks Lynn,

    Did you apply the Up Armor Yello topically or lightly mist on w/airbrush?

    Loranar

Similar Threads

  1. My Armor Problems
    By Marx Tandish in forum Expanded Universe Bounty Hunters
    Replies: 4
    Last Post: Jul 28, 2009, 7:17 PM
  2. Collar Armor Problems
    By webchief in forum Boba Fett Costume
    Replies: 15
    Last Post: Dec 6, 2004, 12:14 AM
  3. Yellow weathering on armor
    By BountyHunter185 in forum Boba Fett Costume
    Replies: 14
    Last Post: Nov 13, 2004, 3:33 AM
  4. yellow on cod differenent than rest of armor?
    By padawan_schlicher in forum Boba Fett Costume
    Replies: 4
    Last Post: Jul 19, 2004, 9:40 PM
  5. Anyone had problems with FG Knee armor cracking?
    By Rodann in forum Boba Fett Costume
    Replies: 19
    Last Post: Mar 16, 2004, 10:30 AM